Did you know that your browser is out of date?
As of February 15th you will be required to update your browser to access Amway.com
View Minimum Browser Requirements or select your browser to update now      
You are here: Home / Support / Website Support / Minimum Browser Requirements

Minimum Browser Requirements


Amway.com has been optimized for Microsoft IE 11+, Safari 7+, Firefox 33+, Chrome 37+. Amway’s mobile website m.amway.com has been optimized for Safari 7+, Chrome 30+.

If you do not choose to use any of these browsers, you may experience difficulty viewing some areas of our Web site.

To update your browser, please visit: www.mozilla.com/firefox, www.microsoft.com/ie, www.apple.com/safari, or www.google.com/chrome.

Mobile minimum requirements:

  • iOS – 9.x.x, 10.x.x
  • Android – 4.1.x, 4.2.x, 4.3, 4.4, 5.0

Additionally, selected sections of the new Amway.com rely upon the user installing browser plug-ins to support the following:


For further assistance, Contact Us.